Unit errors on existing components when testing

Hi! I’ve been trying to submit a commit through running arc diff, but when running the tests It throws errors on components that are not the ones I did make. So, could someone help me to figure this out? :thinking: I don’t know exactly what should I do

Had the same issue, uninstalling arc and reinstalling it using these instructions fixed it for me.

I did it already, but the test’s failures persists.

The error that throws in every component is the same, cannot find module:

Error: Cannot find module '/home/xander/work/seal/sealious-playground/webhint/node_modules/.bin/hint'
    at Module._resolveFilename (node:internal/modules/cjs/loader:1143:15)
    at Module._load (node:internal/modules/cjs/loader:984:27)
    at Function.executeUserEntryPoint [as runMain] (node:internal/modules/run_main:142:12)
    at node:internal/main/run_main_module:28:49 {
  requireStack: []

I solved it! I had to run npm install inside the webhint directory and it installed the missing dependencies

Ah, nice catch! I’ll add them to the postinstall script so it doesn’t happen in the future :pray: